Home » 1С Предприятие 8.х Готовые решения » Расширяем конфигуратор без Снегопата и ТурбоКонфа
google




Расширяем конфигуратор без Снегопата и ТурбоКонфа

При выходе новых релизов Снегопат не всегда быстро актуализируется. Набор скриптов с использованием Autohotkey позволяет упросить работу в конфигураторе. Часть функционала дублирует возможности скриптов для снегопата, часть уникальна.

Теперь не требуется регистрация каких-либо dll

 

Если кто желает присоединиться к разработке / просмотреть историю изменений — добро пожаловать:

https://github.com/ret-Phoenix/v8CfgAddsAhk

 

Важно: имеется возможность перенастроить горячие клавиши, для этого редактируется файл v8CfgAdds.ahk

Реализованные функции

Работа с метаданными:

— Навигация по метаданным: {ctrl + shift +j}

— Навигация по входящим в объект типам: {ctrl + j}

— Поиск метаданных по имени: {Ctrl+k}

Работа с методами:

— Вызов списка методов: {ctrl +1}

— Переход в начало метода: {Ctrl+b}

— Переход в конец метода: {Ctrl+e}

— Препроцессор метода: {Alt+7}

— Переход в процедуру: {ctrl+enter}

— Возврат на предыдущую позицию: {Alt,-}

Прочие операции с текстом:

  • Поиск с рег.выражениями: {Alt+f}
  • Поиск с рег.выражениями (результат последнего поиска): {Alt+r}
  • Выбор ранее набранных слов + Выбор заранее заготовленных слов\фраз (файл words.txt в корне директории скриптов): {ctrl+w}
  • Переход по областям: {Ctrl+2}
  • Закоментировать строку: {ctrl + / (ctrl + .)}
  • Развернуть модуль: {ctrl+i}
  • Удаление строки: {Ctrl+y}
  • Авторские комментарии:
    • блок добавлен: {alt+a}
    • блок изменен: {alt+e}
    • блок удален: {alt+d}
  • Cимвол ‘<‘: {Ctrl-,}
  • Cимвол ‘>’: {Ctrl-.}
  • Cимвол ‘|’: {Ctrl-}
  • Cимвол ‘&’: {Ctrl-&}
  • Cимвол ‘[‘: {Alt-[}
  • Cимвол ‘]’: {Alt-]}
  • Копирование текущей строки и вставка в следующей: {ctrl+d}
  • Добавление ссылки на основной реквизит в модуле (преобразование модуля формы из обычных форм в управляемые): {Alt+h}
  • Генератор кода для объектов метаданных (требуется предварительная генерация файла структуры обработкой v8CfgAddsAhk\ext\ПолучениеСтруктуры.epf): {Alt+g}
  • Выделение в верхний регистр
  • Выделение в нижний регистр
  • Выделение в нормальный регистр
  • Выравнять по равно
  • Выравнять по первой запятой
  • Выравнять по выбранному значению
  • Очистить модуль (убирает комментарии (исключения в скрипте), лишние пустые строки (оставляет только 1 пустую), убирает пробелы в конце строк)
  • Убрать пробелы на конце строк
  • Установка/Удаление ‘|’
  • Показать последний список выбора {shift + alt + r}
  • Обрамление выделенного текста конструкциями:
    • Если … Тогда
    • Пока .. Цикл
    • Для По Цикл
    • Для каждого Из Цикл
    • Попытка .. Исключение
    • Область
  • Автозамена Переменная ++ Переменная += Переменная — Переменная -=

Прочие скрипты:

  • Открытие внешних отчетов/обработок, файлов конфигурации: {Ctrl + 3}
  • Менеджер скриптов (обработка выделенного блока, автоматическое добавление скриптов из папки auto): {Ctrl + shift + m}:
  • Пример работы с меню {Win + X}:
    • Быстрый выбор:
      • КонецЕсли;
      • КонецЦикла;
      • КонецПроцедуры;
      • КонецФункции
    • Выравнивание выделения по знаку равно

 

Установка

Установить Autohotkey (http://www.autohotkey.com/)

Запуск

Необходимо преключиться на Eng раскадку (хоткеи написаны без скан кодов и аналогов на Rus раскладке)

v8CfgAddsAhk\v8CfgAdds.ahk (Основной набор скриптов)

v8CfgAddsAhk\continueRow.ahk (Операции по переносу комментариев, строк). Автор ADirks

Как это работает

При помощи Autohotkey назначаются управляющие сочитания клавиш (хоткеи). На языке Autohotkey описываются действия посылаемые платформе: оправляются нажатия клавиш, получается текст из буфера, читаются и записываются файлы.

Разберем работу скриптов на основе вызова списка методов (процедур/функций):

1. Получаем текст модуля (шлем Ctrl+A и Ctrl+ins)

2. Записываем полученный в буфер обмена текст в служебный файл (tmp\module.1s)

3. Запускаем скрипт парсинга модуля

4. Полученный список методов записываем во временный файл

5. Запускаем приложение выбора из списка: SelectValueSharp

6. Получаем номер строки выбранной функции (указывается в списке выбора перед названием метода) и возвращаем в ahk

7. AHK вызывает хоткей перехода к строке (Ctrl + G) и вставляет номер строки, полученный при выборе метода, подтверждает переход к строке

Для обмена между скриптами текстом используются текстовые файлы. Скрипты читают файл источник, обрабатывают и перезаписывают файл, который потом считывается ahk в буфер обмена и вставляется стандартным способом (Ctrl + V). Используя менеджер скриптов можно обрабатывать выделенный фрагмент кода. При использовании менеджера текст берется в буфер, обрабатывается выбранным скриптом и не снимая выделения вставляется результат. Скрипты находящиеся в папке auto добавляются в список выбора менеджера, при этом подразумевается что никаких входящих параметров скриптам передевать не надо. Если требуется организовать выбор или ввод данных для автоскрипта используется внешнее приложение, в поставку входит пример: auto\ОбрамлениеКода.os. Выбор обрамления происходит вызовом приложения SelectValueSharp. К автоматически добавляемым относятся файлы с раширением: os, js

При желании можно сделать exe файл, инструмент включен в Autohotkey.

Примеры

Список процедур + переход к процедуре

Список процедур + переход к процедуре

 

Поиск с регулярными выражениями

Поиск с регулярными выражениями

 

Генератор кода

Генератор кода

 

Команды препроцессора + Авторские комментарии

Команды препроцессора + Авторские комментарии

 

Навигация по метаданным

Навигация по входящим в объект типам


Posted on by Ушаков Сергей
Categories: 1С Предприятие 8.х,Готовые решения Метки: ,,,



4 комментария на «“Расширяем конфигуратор без Снегопата и ТурбоКонфа”»

  1. Спасибо, попробовал Вашу разработку, что то работает, что то нет. М.б. не правильно установил. Авторские комментарии, например, работают с большой задержкой, или не работают.
    .Автозамена тоже Пишу А+= , жду что будет А=А+1; но ничего не происходит. и т.д.
    Но что то и работает.
    По установке толково написано-Установить Autohotkey (http://www.autohotkey.com/)
    а вот дальше проблемы,
    v8CfgAddsAhk\v8CfgAdds.ahk (Основной набор скриптов, раскладка при запуске значения не имеет) v8CfgAddsAhk\continueRow.ahk (Операции по переносу комментариев, строк). Автор ADirks
    Куда их скопировать в какой корень, какого проекта и потом запускать при включении компа?

  2. Ушаков Сергей:

    Обновитесь, 2017-10-09 было обновление. Ускорено выполнение всех скриптов.
    Последний релиз привнес большое количество изменений внутри набора.

    копировать что? не понимаю.
    Скачали набор скриптов, запустили ahk файл (либо установив привязку к autohotkey, либо передали как параметр) и все.

  3. Спасибо, я так и сделал (запустили ahk файл), просто некоторые скрипты не работали, и я подумал что что то не так установил. С autohotkey сталкиваюсь в первый раз, поэтому туплю, (либо установив привязку к autohotkey, либо передали как параметр) — не знаю как.
    Но и так хорошо. Сейчас обновлюсь

    • Ушаков Сергей:

      обычный запуск с параметром: AutoHotkey\AutoHotkeyU64.exe v8CfgAddsAhk\smartconfigurator.ahk
      После релиза еще эту статью не обновил…. Актуальное описание в readme.md

Добавить комментарий

Войти с помощью: 

Социальные сети


Я в Twitter
Яндекс.Поиск
Поиск обычный
Счетчики
Рейтинг@Mail.ru Яндекс.Метрика